IPMI命令重启BMC超时问题

问题描述

BMC长时间重启测试,IPMI下发重启命令成功,1分钟内未重启,影响长时间测试 出现概率:1/47

环境信息

  • 操作系统:[如 Ubuntu 24.04]

  • 软件版本:[如 OpenUBMC2509]

  • 硬件配置:[如 CPU、内存等]

重现步骤

IPMI命令下发,进行BMC长时间重启操作

期望结果

BMC可以在1分钟之内进行重启

实际结果

偶现BMC超过1分钟不会重启,出现概率1/47

分析结论

从framework.log日志排查,ssdp模块启动异常,导致重启BMC超时异常
maca ERROR: init.lua(62): [ssdp]HealthCheck failed, error: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
具体分析见BMC概率性冷重启失败问题
涉及ssdp闭源模块,需要排查为啥ssdp模块启动失败
从app日志看:(ssdp出现8个小时时间差距)

启动问题比较复杂,能复现问题后,立马收集一份一键收集日志,让我们分析下吗

邮件已发送一键收集日志,请分析下

请发到这个邮箱:ouyiwen1@h-partners.com

咨询下,IPMI命令冷复位BMC重启,为什么会判断ssdp服务是否启动正常呢?如果异常难道BMC就不会重启了吗?

ssdp服务启动异常是由于使用的dbus库存在缺陷导致偶发性coredump,bmc重启确实会因为组件无法响应平滑重启而失败

bmc重启为什么会依赖组件响应呢?如果组件无法响应,就会导致bmc重启失败,不太服务实际使用场景吧

bmc有两种重启方式,一种是平滑重启,依赖各个组件都处理完成后才会重启bmc,另一种是强制重启,不需要组件响应就可以重启bmc