LCC
(Hkzy_licuncai)
2026 年4 月 10 日 06:30
1
// 此模板仅供参考,如果不适用可以修改
问题描述
在长稳测试过程中,某次重启BMC后,发现BMC IP不同,通过带内查看BMC IP变成默认IP
尝试通过ssh登录BMC,发现一直报密码错误,但实际密码没有变动;然后尝试新增管理员登录bmc,发现ipmi命令发送失败:
后续通过BIOS重置密码,才正常登录BMC
最后一次重启的时间点是20:27
查看框架日志,发现在该时间点前,出现大量的数据库持久化失败打印
怀疑是不是数据库文件被破坏了?希望社区可以定位下这个问题
环境信息
openUBMC 25.12
重现步骤
BMC reset长时间测试
期望结果
BMC reset长时间测试功能稳定
实际结果
重启过程中出现数据库被损坏
尝试过的解决方案
[列出您已经尝试过的解决方案及结果]
分析结论
怀疑数据库文件被破坏,用户名的密码感觉也被损坏了,无法登录
LCC
(Hkzy_licuncai)
2026 年4 月 10 日 06:45
4
日志(太大分卷压缩的):
dump_info.z01.txt (8 MB)
dump_info.zip (3.6 MB)
看日志是尝试写一个只读的数据库,是不是环境上数据库的权限被改过,或者文件被删除、被替换。这种一般是认为干预的。
LCC
(Hkzy_licuncai)
2026 年4 月 10 日 06:58
6
这个不大可能,因为跑BMC长稳都是在晚上运行,也没有开发会偷偷去修改数据库权限,我感觉在BMC运行过程中数据库权限被篡改或数据库损坏更有可能。
而且我只是设置用户名会失败,但是我重新修改BMC IP是正常的,修改BMC IP也会更新数据库嘛,如果是权限问题,应该也会失败吧。
LCC
(Hkzy_licuncai)
2026 年4 月 10 日 07:00
7
或者有没有其他的可能会导致ip恢复成默认?主要是我还发现一个现象:通过ipmitool user set name去添加用户,会报错,说当前用户已存在,但实际是不存在的。
通过web新增相同user id的用户之后,在通过web删除,然后再次通过ipmitool user set name添加用户,这次就会成功,感觉就像数据库有脏数据一样
可能是执行用例的问题,不一定是真的有开发上环境操作。
LCC
(Hkzy_licuncai)
2026 年4 月 10 日 07:56
9
用例只是单纯的在跑cold reset,没有做其他操作,这个是概率性出现的问题
数据库没那么容易损坏,也不会有权限篡改的可能,这种通常就是人为的